Results 1 to 9 of 9
  1. #1
    Join Date
    Feb 2017
    Location
    Paducah, Kentucky
    Posts
    20
    Downloads
    0
    Uploads
    0

    Default I can't play now! BF4 Required me to download Latest Plugin

    BF4 Required me to download Latest Plugin to play online all of a sudden. I downloaded it, installed it and hit the Continue button like it asked. NOTHING! I uninstalled and reinstalled... NOTHING!!!! OMG WTF

  2. #2
    Join Date
    Nov 2016
    Location
    Calgary, Canada
    Posts
    461
    Downloads
    2
    Uploads
    0

    Default Re: I can't play now! BF4 Required me to download Latest Plugin

    Generally the fix requires you to restart your battlelog Brower or your computer.
    If that doesn't work try deleting the battlefield 4 folder in your documents folder.
    "Any sufficiently advanced technique is indistinguishable from hacking" - Undertaker

  3. #3
    Join Date
    Feb 2017
    Location
    Paducah, Kentucky
    Posts
    20
    Downloads
    0
    Uploads
    0

    Default Re: I can't play now! BF4 Required me to download Latest Plugin

    I fixed it by uninstalling Firefox and running the game without plug-in Option... WTF? they made an update that doesn't work with BF4?

  4. #4
    Join Date
    Feb 2017
    Location
    Paducah, Kentucky
    Posts
    20
    Downloads
    0
    Uploads
    0

    Default Re: I can't play now! BF4 Required me to download Latest Plugin

    But now I'm getting hell of pop ups on this SITE??

  5. #5
    Join Date
    Nov 2016
    Location
    Calgary, Canada
    Posts
    461
    Downloads
    2
    Uploads
    0

    Default Re: I can't play now! BF4 Required me to download Latest Plugin

    Strange. Though it was a while ago that chrome updated and broke the battlelog plug-in. Since then it's worked great running in the plug-in free mode.
    "Any sufficiently advanced technique is indistinguishable from hacking" - Undertaker

  6. #6
    Join Date
    Nov 2016
    Location
    Calgary, Canada
    Posts
    461
    Downloads
    2
    Uploads
    0

    Default Re: I can't play now! BF4 Required me to download Latest Plugin

    I believe you can disable the pop-ups.
    "Any sufficiently advanced technique is indistinguishable from hacking" - Undertaker

  7. #7
    Join Date
    May 2015
    Location
    Colorado
    Posts
    1,061
    Trophies
    Downloads
    2
    Uploads
    2

    Default Re: I can't play now! BF4 Required me to download Latest Plugin

    Quote Originally Posted by sgtcoldbeer View Post
    But now I'm getting hell of pop ups on this SITE??
    What do you mean pop ups on this site? This site has none unless your receive a pm from someone

  8. #8
    Join Date
    Mar 2017
    Posts
    3
    Downloads
    0
    Uploads
    0

    Default Re: I can't play now! BF4 Required me to download Latest Plugin

    I seem to be getting the same thing now. When I try to start a game from battlelog I get an annoying box that says "download and install the latest browser plugin to play the gam". I dl it, execute it, restart firefox, and get the same dialog box. Tried everything I could find online plus the suggestion in this thread, but I can no longer start a game battlelog. I don't much like the new UI but I would use it if I could get battlescreen, but I don't know how to get battlescreen when using the new UI. So anyone else have this issue and solve it?
    I have 100,000 rounds buried in my back yard. When they come for me, I'll put up a wall of lead.

  9. #9
    Join Date
    Nov 2016
    Location
    Calgary, Canada
    Posts
    461
    Downloads
    2
    Uploads
    0

    Default Re: I can't play now! BF4 Required me to download Latest Plugin

    I believe if you're using Firefox you have to change your options to use the "plug-in free" launch option. I'm not quite sure where it is found though a quick check through battlelog settings should yield results
    "Any sufficiently advanced technique is indistinguishable from hacking" - Undertaker

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •